Neotel Outage
Incident Report for Tarsus on Demand
Resolved
This incident has been resolved.
Posted Feb 20, 2018 - 06:22 SAST
Investigating
Dear customer,

Network connectivity to services in Neotel is currently down. We are working quickly to investigate the issue and will update you as we receive more information. Thank you for your patience.

Cloud Master
Posted Feb 16, 2018 - 15:34 SAST